APPLE NEWS

MacOS Monterey users report problems connecting to USB hubs


Some Mac users who upgraded to macOS Monterey this week have trouble getting USB hubs and other USB-based devices to work properly with their machines, based on scattered online reports.

There have been several reports on Reddit, Apple’s developer forums, and Apple’s support communities about the issues. In some cases, users say the USB 3.0 ports on their hub are no longer working since the upgrade to Monterey, while HDMI, USB-C and other hub ports continue to work as expected.

In other user reports that appear online, USB hubs do not work at all. Some of the problems even apply to Apple certified hubs. Reddita user Flyersny81 shares their experience:

My USB-C hub is having problems with this update. The HDMI port connected to my other screen works on the hub, but none of the USB3 ports work at all. I tried different C ports on a MacMini and different hubs (I have 4). I also repeated this problem on my M1 MacBook Air after updating to Monterey. Here are the hubs I use. These hubs worked perfectly in Big Sur.

I had a call with Apple support and they said to try with an Apple certified hub. I used the one that floated in the bag and both the HDMI and USB3 ports worked on it. I tried to connect the Amazon hub to the Apple hub, but it didn’t work either. Support has told me that many people are complaining about this problem and hopefully this will be resolved in the next patch that will be thrown out.

In other cases, USB hubs work other than the power port. For some, the extra connectivity provided by external displays no longer works, and especially affects power delivery. From the Apple Developer Forum:

PD (Power Delivery) via USB-C also stopped working on my MBP 2018 after an update to Monterey (12.0.1). I use Philips 346P1CRH. Everything worked flawlessly with the Big Sur.

– TommyWi

I have the same problem with my MBP M1 2020 connected to the HP S340c external monitor. Power delivery (PD) and video connection do not work (but mouse and keyboard are still supported / working).

– Begging

Same problem as everyone, bought a 34 “Philips 346P1CRH / 00 and everything worked fine on BigSur … After the update on Monterey, the video and ethernet work, but the power is cut off. I’m on an M1 Macbook Air.: /

– lenskdav

In essence, Monterey has discontinued support for a number of USB hubs. Some USB hubs work, but certain ports on the hub do not, some hubs do not work at all.

For me, USB-C and HDMI work on the hub, but my USB 3.0 port will only power devices and there seems to be no data transfer.

This question is absolutely Monterey’s fault. My devices worked well before the upgrade and I was able to replicate the problem and narrow it down by testing on a device that didn’t have Monterey installed.

– macmjs1996

Many of the reports are from M1-powered Mac owners, but not all. Some users have reported similar problems on Intel Macs. Based on user discussions, USB issues have been reported in the early beta versions of Monterey, suggesting that this could be due to an inherited bug that Apple has not yet patched.

As such, problems appear to be evident in all versions of Monterey, including the latest version 12.0.1. Suffice it to say that anyone who has yet to upgrade to Monterey and relies on a USB hub is advised to postpone the upgrade until Apple issues a fix.



Source link

Naveen Kumar

Friendly communicator. Music maven. Explorer. Pop culture trailblazer. Social media practitioner.

Related Articles

Leave a Reply

Your email address will not be published.

Back to top button